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Outline
• Introduction to the problem. 

• Solutions: 

• Thresholding. 

• Region growing. 

• Clustering. 

• Morphological segmentation. 

• Trainable segmentation. 

• Hands-on tutorial.
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Image Segmentation
• “Process of partitioning a 

digital image into multiple 
segments”. 

• Typically used to locate 
objects and boundaries. 

• More precisely, image 
segmentation is the process 
of assigning a label to every 
pixel in an image such that 
pixels with the same label 
share certain visual 
characteristics.
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Image 
Segmentation 

Methods

Thresholding

Region based 
methods 
(region 

growing…)

Clustering 
(k-means, 

mean shift…)

Graph based 
methods 

(graph-cut…)

Shape based 
methods (level 

sets, active 
contours…)

Morphological 
methods 

(Watershed)

Machine 
learning based 

methods

http://imagej.net/Category:Segmentation

http://imagej.net/Category:Segmentation


Basics of Image Segmentation
• Definition: Image segmentation partitions an image into regions 

called segments. 

• Image segmentation creates segments of connected pixels by 
analyzing some similarity criteria: 

• intensity, color, texture, histogram, features…
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Image binarization
• Image binarization applies often just one global 

threshold p for mapping a scalar image I into a 
binary image
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O(i, j) =

(
0 if I(i, j)  p,

255 if I(i, j) > p

• The global threshold can be identified by an 
optimization strategy aiming at creating “large” 
connected regions and at reducing the number 
of small-sized regions, called artifacts.



Image binarization
• Thresholding: Most frequently employed method 

for determining threshold is based on histogram 
analysis of intensity levels.
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Peak on the left of the histogram corresponds 
to dark objects 

Peak on the right of the histogram 
corresponds to brighter objects 

DIFFICULTIES: 

1. The valley may be so broad that it is difficult 
to locate a significant minimum 

2. Number of minima due to type of details in 
the image 

3. Noise 

4. No visible valley 

5. Histogram may be multi-modal

Brighter objects

Darker 
objects



Manual thresholding example
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original image thresholded image

In the ImageJ menu: Image  ▶ Adjust  ▶ Threshold...



Too low or too high?
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threshold too low threshold too high



How to choose?
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Automatic selection of threshold
• Same threshold over a collection of images? NOT recommended 

due to fluctuations in intensity across images. 

• Automatic threshold methods: 

• optimizing some objective criterion that can be: 

• statistical (e.g., maximization of inter-class variance, 
entropy…), 

• probabilistic (e.g., minimization of pixel classification 
error…), 

• structural (e.g., circularity of detected objects…). 

• How to choose in Fiji? Try them ALL!
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Edge detection
• Objects without homogeneous intensities. 

• Contours easily identifiable by their contrast 
difference with the background. 

• Task:  

• Segment the image by finding relevant 
edges. 

• Simple Way:  

• Smooth the image (Gaussian blur, median…). 

• Calculate gradient (Sobel operator). 

• Post-process to create continuous borders 
and close objects (Canny).
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Gradient magnitude

Non-max suppression

Hysteresis thresholding
http://imagej.net/plugins/canny/index.html
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Connected component labeling
• Transform a binary image into a label image 

• Label ⇔ particle ID 

• Several algorithms: 

• Raster scan + labels merge 

• Flood-fill 

• Breadth-first 

• Depth first 

• Line based 

• Need to specify connectivity (2D: 4-8, 3D: 6-26)
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Region based segmentation
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Region based segmentation 
basics

• Region: 

• A group of connected pixels 
with similar properties 

• Closed boundaries 

• Computation of regions is 
based on similarity 

• Regions may correspond to 
objects in a scene or parts of 
objects 

• Spatial proximity + similarity
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Region growing
• For segment generation in grey-level or color 

images, we may start at one seed pixel (x,y,I(x,y)) 
and add recursively adjacent pixels that satisfy a 
“similarity criterion” with pixels contained in the 
so-far grown region around the seed pixel. 

• Defining similarity criteria alone is not an effective 
basis for segmentation. 

• It is necessary to consider the adjacency spatial 
relationship between pixels.
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Region growing algorithm
1. The absolute intensity difference between candidate pixel 

and the seed pixel must lie within a specified range. 

2. The absolute intensity difference between a candidate 
pixel and the running average intensity of the growing 
region must lie within a specified range. 

3. The difference between the standard deviation in 
intensity over a specified local neighborhood of the 
candidate pixel and that over a local neighborhood of the 
candidate pixel must (or must not) exceed a certain 
threshold.
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Ex: Muscle/Bone Segmentation in 
CT Scans

Threshold
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Ex: Muscle/Bone Segmentation in 
CT Scans

Threshold



Pros and cons of region growing
• Advantages： 

• Can correctly separate regions that have the same properties we define. 

• Can provide the original images which have clear edges with good 
segmentation results. 

• Simple. We only need a small number of seed points. 

• We can choose the multiple criteria at the same time. 

• Disadvantages： 

• Computationally expensive. 

• It is a local method with no global view of the problem. 

• Sensitive to noise.
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Level Sets

• Based on partial differential equations (PDE). 

• Progressive evaluation of the differences among neighboring pixels to find 
object boundaries. 

• Converge at the boundary of the object where the differences are the highest. 

• Two methods: Fast Marching and Active Contours.
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Fast marching and Active Contours

• Fast marching: 

• Similar to standard flood fill but 
more sensitive in the boundary 
detection. 

• Sensitive to leaking. 

• Active contours: 

• Slower. 

• Prevents leaking.

29
http://imagej.net/Level_Sets

http://imagej.net/Level_Sets


Region splitting and 
merging Segmentation

• Region splitting: 

• Unlike region growing, which starts from a set of seed points, 
region splitting starts with the whole image as a single region 
and subdivides it into subsidiary regions recursively while a 
condition of homogeneity is not satisfied. 

• Region merging: 

• Region merging is the opposite of splitting, and works as a way 
of avoiding over-segmentation. 

• Start with small regions (2x2 or 4x4 regions) and merge the 
regions that have similar characteristics (such as gray level, 
variance).
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Region splitting Segmentation
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• Quadtree for splitting 
(topdown) procedure 

• RAG: region 
adjacency graph



Split and Merge Region 
algorithm

1. Start with the entire image as a single region. 

2. Pick a region R. If it is inhomogeneous (P(R) is false), 
then split the region into four subregions. 

3. Consider any two or more adjacent regions, R1, R2,..., 
Rn, in the image. If they are homogeneous  P(R1 U R2 
U. .. U Rn) is true), merge the n regions into a single 
region. 

4. Repeat steps 2-3 until no further splits or merges 
take place.
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Statistical Region Merging plugin

• Fast and robust algorithm to 
segment an image into regions 
of similar intensity or color. 

• Start with one region per pixel. 

• Then apply statistical test on 
neighboring regions to check if 
mean intensities are similar 
enough to be merged. 

• Only 1 parameter: Q 
(estimated number of regions).
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Clustering based 
segmentation methods



What is Clustering?

• Organizing data into classes such that: 

• High intra-class similarity 

• Low inter-class similarity 

• Finding the class labels and the number of 
classes directly from the data (as opposed to 
classification tasks)
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What is natural grouping?
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Clustering is subjective!

Simpson family School Employees Females Males



What is similarity?
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What is similarity?
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Cluster by features 
• Color 
• Intensity 
• Location 
• Texture 
• …



Distance metrics
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K-means clustering
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K-means clustering

x

x
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K-means clustering

x

x
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K-means clustering

x
x
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K-means clustering

x
x
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K-means clustering

x x
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K-means clustering

x x
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K-means clustering

x

x
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K-means clustering limitations
• Heuristic algorithm, there is no guarantee that it will converge to global optimum. 

• The result may depend on the initial clusters. 

• Based on spherical clusters that are separable in a way so that the mean value 
converges towards the cluster center. 

• The clusters are expected to be of similar size.
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Segmentation via K-means in RGB 
space

R

G B

Use K-means algorithm in RGB 
space to assign pixels to K 
clusters.
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K=6
http://imagej.net/Trainable_Weka_Segmentation

http://en.wikipedia.org/wiki/K-means_algorithm
http://imagej.net/Trainable_Weka_Segmentation


Morphological segmentation 
methods
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Watershed Segmentation
• Use a topographic analogy 

• Principle: 

• Consider grey levels as 
altitudes 

• Identify local minima 

• Flood basins starting from 
minima 

• Separate the basins by a 
“dam” → the watershed

51
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Watershed limitations
• Over-segmentation (too many regions) 

• due to the presence of many local minima
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original image watershed segmentation local minima



Solutions to over-segmentation
• Idea: remove unwanted minima 

• Filtering of input image (Gaussian, median...) 

• Automatically detect minima 

• Use extended minima
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Implemented with GUI

Plugins ▶ MorphoLibJ ▶ Segmentation ▶ Morphological Segmentation

56



More on watershed: 
segmentation of contrasted object

• Idea: apply watershed on gradient of image 

• Gradient can be of any type (linear, morphological)...
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More on watershed:  
separation of binary particles
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input image touching nuclei separated nuclei

distance map WS on inverse 
of distance map

watershed 
lineshttp://imagej.net/Distance_Transform_Watershed

http://imagej.net/Distance_Transform_Watershed


Machine learning based 
segmentation
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Machine learning
• Subfield of computer science that "gives computers the ability to learn without being 

explicitly programmed" (Arthur Samuel, 1959). 

• Assign labels to objects indicating their class. 

• Objects represented by a set of measurements or features.
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Supervised vs unsupervised learning
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x1

x2

x1

x2

Supervised Unsupervised



Supervised vs unsupervised learning
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x1

x2

x1

x2

Supervised Unsupervised

• To which class belongs each new point x?

x x
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Pixel classification

http://fiji.sc/Trainable_Weka_Segmentation

Input Image features 

Input 
labeling Training set

Classifier

Segmentation

Trainable Weka Segmentation

http://fiji.sc/Trainable_Weka_Segmentation


Pixel classifier versatility
• As a pixel classifier, the 

Trainable Weka 
Segmentation presents a 
wide range of applications: 

• boundary detection, 

• semantic segmentation,  

• object detection, 

• object localization…
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Take home messages
• There is no universal segmentation method. 

• It is recommended to try different approaches to 
determine which one works best for our specific 
image data. 

• Advices: 

• Keep image acquisition conditions fixed. 

• Normalize intensities to reuse successful methods.
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Hands-on Tutorial



Arabidopsis embryo (LM)
• Open arabidopsis-embryo.zip 

• Set correct calibration (1,1,3). 

• Try segmenting by manual 
thresholding (Image > Adjust 
> Threshold…) 

• Try automatic threshold on a 
slice (Image > Adjust > Auto 
Threshold) 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• Try automatic threshold on stack 
(Image > Adjust > Auto 
Threshold) 

• Try Morphological Segmentation 
(Plugins > MorphoLibJ > 
Segmentation) on slice (2D) 

• Try Morphological Segmentation 
(Plugins > MorphoLibJ > 
Segmentation) on stack (3D)  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• Try automatic threshold on stack 
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Drosophila embryo (TEM)
• Open test-volume-1.tif 

• Call Trainable Weka Segmentation 
(under Plugins > Segmentation) 

• Trace 

• Train 

• Get results and probabilities 

• Apply to test-volume-2.tif 

• Balance classes 

• …
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Unsupervised learning 
example

• Open sample “Fluorescent 
Cells”. 

• Convert to RGB and remove 
text. 

• Call TWS. 

• Use ClassificationViaClustering 
with 

• SimpleKMeans (K=4) 

• EM 
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